aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorroot <root@rbsd.ankarstrom.se>2021-04-24 00:56:05 +0000
committerroot <root@rbsd.ankarstrom.se>2021-04-24 01:11:06 +0000
commit72c681d3a16a706b0a3dd2b6dda95edcb4f78f51 (patch)
tree980d08083ae4e5208c85d54bd34f01457f721fb3 /Makefile.PL
parent5cfdae7ccf1eece314c381d8de52acd2aee7cff9 (diff)
downloadApache-Inject-72c681d3a16a706b0a3dd2b6dda95edcb4f78f51.tar.gz
Add Makefile, basic test
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..bf6e6f1
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,23 @@
+#!/usr/bin/perl
+
+use 5.008000;
+
+use ExtUtils::MakeMaker;
+
+use lib qw(../blib/lib lib);
+
+use Apache::TestMM qw/test clean/;
+
+Apache::TestMM::filter_args();
+Apache::TestMM::generate_script('t/TEST');
+
+WriteMakefile(
+ NAME => 'Apache::Inject',
+ VERSION_FROM => 'lib/Apache/Inject.pm',
+ PREREQ_PM => { Apache::Test => 0 },
+ ABSTRACT_FROM => 'lib/Apache/Inject.pm',
+ AUTHOR => 'John Ankarström <john@ankarstrom.se>',
+ LICENSE => 'perl',
+ clean => { FILES => "t/TEST" },
+ dist => { PREOP => 'pod2text lib/Apache/Inject.pm > $(DISTVNAME)/README' },
+);